Moving house

1–10 of 36

Hi everybody, As you may know, this website has experienced many small outages over the past two months. I have now migrated the website onto an AWS Linux cloud infrastructure. This platform should provide a lot of scope to scale up or out as needed, as well as being more cost-effective. Historically, the website was served out of the US, which is a long way away for the predominantly NZ audience. It now lives in Sydney, Australia, which is a lot closer to home. As the migration has required a very substantial amount of application code rewriting, there may be some bugs. Please let me know if anything is not working. Fixing these up is priority work. Thank you for your forbearance. Cheers, Matthew
I can't seem to access my profile and my avatar is an old pic from ages ago.
Thumbs up
The previously fixed problem of pictures showing as grey boxes is still a problem fof me (Samsung browser Ver Not related to the migration but not fixed by it either 🤔 That'll learn ya, gaiters, for changin' ya avatar 😁. Mine is OK but can't access the profile either - generates the following error : The key [USER] does not exist in the request scope.
Thanks! - Profiles are clearly broken. I'll sort that out. - Avatars should be fixed soon. - Pictures issue, thanks. So, you're saying it was working? When was it working?
This might be profile related. The remember my tick box isnt working when you sign in. It ticks ok but doesnt auto log in next time
Thumbs up
The pictures broke in April This first happened back in Aug 2017 You fixed it then but ....
Here are a few more : 1. (many) pictures also not loading (ie showing as grey boxes) in Chrome and FF on Win10 PC 2. Clicking an 'alert' link on a photo page (eg Cobb Valley 16432) crashes with error : *Can't cast Complex Object Type Struct to String* 3. Clicking on a user link when not logged in crashes with error : *component [whio.models.anonymoususer] has no function with name [canMailRecipient]*
OK fixed: - Alerts - Profiles - Avatars
@bernieq where are these user links that are failing? I can't replicate the issue so far.
If not logged in, clicking on a username link (eg Matthew - top left of your previous post), it crashes out to an unmanaged error. On the contrary (still not logged in), clicking on @username does work (and takes you to the user's page) eg @bernieq works.
Thumbs up
1–10 of 36

Sign in to comment on this thread.

Search the forums

Forum This website
Started by matthew
On 10 June 2018
Replies 35
Permanent link

Formatting your posts

The forums support MarkDown syntax. Following is a quick reference.

Type this... To get this...
Italic *Italic text* *Italic text*
Bold **Bold text** **Bold text**
Quoted text > Quoted text > Quoted text
Emojis :smile: :+1: :astonished: :heart: :smile: :+1:
:astonished: :heart:
Lists - item 1
- item 2
- item 3
- item 1 - item 2 - item 3
Images ![](URL/of/image)

Mentions @username @username

Find more emojiLearn about MarkDown